
Customising WebPlus
This tutorial is specific to WebPlus, but some tips also apply to PagePlus,

DrawPlus,, and PhotoPlus. WebPlus allows users to customise the toolbars, menus,
workspace tabs, and keyboard shortcuts. If you use any Serif programs regularly, its
well worth the effort to configure the interface to suit your personal preferences.

Toolbars
See the topic: “Customising Toolbars, Menus, and Tabs” in the help file.

Large Icons
WebPlus X8 has HiDPI support. WebPlus X7 or later have options for small,

large, or auto icons. Import 18 x 18 pixel icons into the Button Editor, or use Paste
Button Image from the context menu while customising toolbars. In earlier versions
the Windows registry can be edited to change the value of the “LargeIcons” key
from zero to one, e.g. for WebPlus X5 there are two keys:–

[HKEY_CURRENT_USER\Software\Serif\WebPlus\13.0\ToolBars\WebPlus\Options]
"LargeIcons"=dword:00000001
[HKEY_CURRENT_USER\Software\Serif\WebPlus\13.0\ToolBars\WritePlus\Options]

"LargeIcons"=dword:00000001

Other Serif Applications are similar.

Creating New Toolbars
I recommend adding a new toolbar for each

side of the window where you want to dock
toolbars. Changes are lost if you reset the work-
space, so save the workspace and copy the *.wtb
file from the %AppData% workspace folder to
keep as a backup. Open the Options dialogue from
the Tools menu, select “Toolbars” and add a new
toolbar. I added one named “Standard Plus.” Display all the toolbars, select the
customize tab on the options dialogue, and drag the toolbars by their handles. The
new toolbars will be empty. Hold down the control key, and drag icons from the
default toolbars, dropping a copy onto the new toolbars.

To make changes on the fly, drag buttons while holding down the Alt key.
To Change a button, right-click on a button and select “Change Button image”

from the popup context menu to open the icon palette.

Adding A New Flyout
At the bottom of the customize tab of the options dialogue is the New Menu

category, which contains two commands: New Menu and New Flyout. A new flyout
can be dragged to any toolbar from the dialogue, or an existing flyout can be copied
by dragging a flyout from any built-in toolbar by holding down the control key.



Detaching Flyouts
The built-in flyouts can be detached as floating toolbar palettes. If you open

a flyout, you will see that it has a drag handle. Drag it away from the toolbar to
detach it as a floating toolbar. The original flyout will not be changed. A floating
toolbar from a copied flyout bears the name of the original flyout from which it
was copied. This name cannot be changed. Floating toolbars can also be docked,
and are automatically added to the list of named toolbars in the Options dialogue.

Sites Toolbar
This non-customisable toolbar with tabs for each open site can be docked or

left floating. It can be set to “Always Hide,” “Show Automatically,” or “Always
Show.” This can be done in Tools, Options, Toolbars, or from the View menu,
so I have removed the submenu from the View menu. Since I rarely work on
more than one site at a time it’s usually hidden, and I dock mine on the right
where it is not wasting precious vertical screen real-estate.

Editing Command Buttons
With the customize dialogue open, right-click

on a flyout, button, or menu to edit its properties.
Change the name, the button, or choose the
button style: default, text, image and text.

If any command, such as the Acquire
command has no button, a new button can be
chosen from the list of custom buttons, pasted
from the windows clipboard, or imported from a
file on disk (Select All Files *.* to include PNG
images). If the image doesn’t have transparency,
add it using the Button Editor’s tools. WebPlus
works best with 18 x 18 pixel icons, but the Custom buttons provided seem to be
only 16 x 16 pixels. Start by adding a Button for saving the workspace, and use it
frequently while working to avoid losing any changes if you plan on doing any
extensive redesigning of the workspaces.

Menus
The menu bar is similar to other toolbars, except that it cannot be disabled. It can

be undocked and moved to any side of the window, moved below other toolbars,
or left floating. Buttons can be positioned on the menu bar, and new menus can be
added. Menu items can also have icons. For example, create a new menu and drag
the recent files item from the file menu to this new menu. Rename the “New Menu”
to “&Recent” so that the access key will be Alter R, and change the access key for
Properties to P, or these two menus will not pull down with Alt R. In Tools, Options,
Text, General, increase the number of recently used files from 4 (max =16). Buttons
and fields (e.g. Zoom) can also be added to the menu bar.



Rearrange menus to allow quick access to frequently used
items, remove items that you never use to save space and make
other items quicker to find. Cascading menus should be
avoided if possible as it hinders workflow. The View menu on
the right has been modified to remove all submenus.

The Zoom submenu has been removed. Using shortcuts for
zooming is much quicker, and I have added the zoom drop list
to the Menu Bar. • The Toolbars submenu has been removed.
Right-click on any toolbar to see it. • The Tabs submenu has
been removed as one can right-click on the borders of the Tabs
to show the Tabs menu. Workspaces can be changed from the
context toolbar when no objects are selected. • The items on
the Select submenu of the Edit menu have been moved to the Edit menu so the
submenu is no longer needed. Using a submenu for just three items is pointless.

Access keys often need to be reassigned after modifying menus. As with the main
menu, avoid using the same access key more than once as it prevents instant access
to menu items. Menu items can be renamed if necessary. Use an Ampersand before
the letter that you wish to use for the access key.

Workspace Tabs
This topic is dealt with under “Customizing Tabs”

in the Customizing toolbars, menus, and tabs help topic.
It is much quicker to access a control that touches the

edge of the screen because the edges of the screen
effectively have infinite width. With the default work-
space there are Tabs on the left and right of the work-
space. That on the right is quick to access, but the Assets
Tab on the left is inside the toolbar, and any tab docked
at the bottom will be above the Hintline.

Move the Assets Tab from the left, and position it floating at the top, where it
can be set to Auto Hide, utilising the free space on the Windows title bar. In this
position, Tabs can be wider. Drag the Styles and Task Monitor Tabs to share the
floating panel with the Assets Tab.

Browse to add some graphics to the Assets Tab, and pin them if you want them
to be available for other documents, but be aware that pinning a lot of large images
will affect the program’s performance.

Save custom workspaces for reloading later. Experiment with different layouts
for different projects. Workspaces are saved in the %AppData% workspace folder,
for WebPlus X8 that is: %AppData%\Serif\WebPlus\16.0\Workspace Profiles\

Don’t forget to save your workspace profile after making changes, and backup
any other customisation data in the %AppData% folder to a safe place. Delete the
bitmap caches first if you want to backup the entire folder for WebPlus.



Keyboard Shortcuts
See the topic “Using shortcuts.”

● Control key shortcuts are easy to use, so assign them to the most used functions.
● Alter key shortcuts are reserved for menu access keys so use them with caution
— you might lose easy access to one of the main menus.
● If your scroll lock key has a light, assign it to snapping on/off
● Assign shortcuts for the rulers and hintline, which are not always needed.
● Assign shortcuts to frequently used styles in the text editing context.
● Backup your keyboard profile in the %AppData% Accelerators folder.

Text S�les
None of the default styles are likely to be exactly what you want, and you may

never use them all. Before starting work, delete any that you don’t want, and modify
the others to suit your needs. Open the Text Styles tab in the panel on the right and
click the drop down arrow by a style to delete it, modify it, or create a new style based
on it. Styles can also be updated from the current selection. Add a toolbar button or
shortcut to make this easier.

Styles based on the current style will be modified if the current style is modified.
Style hierarchy makes it easy to modify the styles throughout a publication, without
modifying each one.

You may wish to modify any of these settings for each paragraph style:

1. Font, font size, text colour, or type style.
2. Justification. Full justification is the most common setting for body text;

headings may be centred or left justified. Force Justified fits the last line.
3. Indents. If there is no spacing between body text paragraphs, it is usual to use

a first line indent to emphasise the beginning of each paragraph. Quotations
may be indented from both margins, and lists may use a hanging indent.

4. Line-spacing can be defined in several ways. The default of single line-spacing
uses a value determined by the font designer. The percentage of pointsize
setting is independent of the font’s design. If exact line-spacing is used, and
the font size is later changed, the line-spacing will not change.

5. Spacing before/after the current paragraph. Web pages are easier to read with
some white space between paragraphs. Saving space is not as much an issue
as in printed publications.

6. Hyphenation is not supported, but soft hyphens can be inserted with Alt 0173.
7. Bullets and numbering. Chose from different bullets, numbers, Roman

numerals, or letters. Restart numbering of lists from any number

Drop Capitals and Initial Capitals are not available in WebPlus. For a
decorative effect at the beginning of a new section, an Artistic Text character
converted to curves or a graphic can be used. Subsequent lines of text will

wrap automatically around the inline image.

http://www.softerviews.org/Fonts.html#OpenTypeFeatures


Nested S�les
The “Heading 1” style used above is based on the “Headings” paragraph style. On

pressing the Enter key the next paragraph is the “Body Text” style. Any changes
made to the Heading 1 style will have no effect on the paragraphs that use the “Body
Text” style, but they will affect paragraphs that use the “Heading 2” style. If the font
is changed, the font used for Heading 2 will change to match. However, if the font
size for Heading 1 is changed the size of the “Heading 2” style doesn’t change because

“Heading 2” has its own size of 16 point.
Any changes to the typeface, point size, line-

spacing, justification, indentation, etc., of the “Body
Text” style will be inherited by its nested styles.
However, any change to the text colour will not be
inherited. The dark green text will be bold, and the
blue text will have 6pt spacing before/after, whatever
changes are made to the weight and paragraph
spacing for “Body Text.” However, if the colour of “Heading 1” is changed to Blue,

“Heading 2” will also change to Blue because the text colour was not part of the
“Heading 1” parent style on which “Heading 2” depends.

Heading 2
Heading 2 is also followed by “Body Text” on pressing the Enter key. It is left

aligned instead of being centred, and has 12 points of spacing before it, but none
after it. “Body Text” has 2 points of spacing before and after, that’s why there is a
gap after Heading 2 before this paragraph.

On the General tab of the Modify Text Style dialogue, one can find a description
of the style attributes that differ from its parent style, on which it is based. In the
above screen shot, you can see that Heading 2 is based on Heading 1, but it is 16
instead of 18 point, and has zero spacing after it.

“Body Text” is automatically followed by another paragraph of “Body Text” style
on pressing the Enter key.

“Red.” This is Body Text, plus the red colour attribute. All paragraphs that use
this style will be just like Body Text, but red. Pressing the Enter key in a paragraph
of red text will automatically select the “Green” paragraph style for the next paragraph.

“Green.” This is Body Text, plus the green colour attribute, and the italic attribute. Pressing
the Enter key in a paragraph of green text will automatically select the “Blue” paragraph
style for the next paragraph.

“Blue.” This is Body Text, plus the blue colour attribute, and an indent on
both sides. Pressing the Enter key in a paragraph of blue text will automati-
cally select the “Red” paragraph style for the next paragraph.

This is the “Red” paragraph style, which automatically follows text using the “Blue”
paragraph style.

http://www.softerviews.org/Fonts.html#OpenTypeFeatures


Object S�les
HE STYLES TAB in WebPlus contains a wide range of predefined object styles

that can be applied to quick shapes, text, or other objects. They are grouped
into categories. Add more using the styles manager.

Anyone with even a little artistic skill can quickly create an unlimited range of
designs by playing with quick shapes and objects styles.

To add, remove, and reorder style categories: click
the Style tab’s menu button and choose Object Styles
Manager... from the flyout menu.

To locate an object style, right-click the object,
and from Format, Object Style, select “Locate in Tab.”
This won’t expand a category if it is collapsed, or
display the Styles Tab if it is on Autohide.

Deleting a style doesn’t affect the appearance of existing objects using that style,
but they are no longer linked to any style. To unlink an object from its style definition:
Right-click the object and choose Format, Object Style, Unlink.

Right-click on a style’s icon in the studio tab to edit its attributes. Editing any of
the attributes used in the style will unlink the object from its style.

Like Text Styles, Object Styles are saved with the current publication. To save
any object styles for use in new publications, select Save Default Settings from the
Tools menu, and enable the “Object styles” checkbox.

CSS S�les
In recent versions of WebPlus, CSS

replaces some of the formatting features used
in earlier versions. For example, borders on
text frames or drop shadows on images can be
applied using CSS Properties, then saved to
the Assets Tab as settings to be reapplied to any other objects on the site.

After defining the CSS Properties for an
object click on the Assets... button on the
Custom CSS dialogue tab, and save the
settings to the Assets Tab. Give it a meaningful
name, and it is then available for reuse elsewhere on the same site.

Although there are lots of options on the CSS Properties dialogue there is almost
no help at all to tell you what values to enter in the various dialogues. You will have
to study some tutorials to find out the right syntax, and as with all such coding, the
slightest error will give unexpected results or no results at all.

See this example thread where I asked how to add a CSS Drop Shadow and found
the solution with the help of more experienced WebPlus users.

http://www.w3schools.com/cssref/css3_pr_box-shadow.asp


Configuring the User Interface
In Tools, Options, General, I recommend disabling “Auto-save temporary file

every 15 minutes.” More often than not, this kicks in at just the wrong time. Cultivate
the habit of saving your site every time you make a minor edit, and use the Save As...
option sometimes if you want to keep different revisions. The temporary files will
only recover work if WebPlus crashes, it won’t protect you from closing the site
without saving changes. Rely on good habits to avoid losing valuable work.

Make backup file on save also won’t protect you from anything if you lose your
hard drive or your computer gets stolen. Establish a regular backup routine to archive
important work to external media. If you fail to do that, don’t complain on the
forums. It obviously was not important at all if you did not keep a backup.

If you work on the same site most of the time, use the On Startup setting to
“Restore Last Session.” This is a huge time-saver on large sites as it remembers not

only the last site or sites that you had open when you last closed WebPlus, but it
remembers which page you were working on at the time, the zoom level, and which
story you were editing in WritePlus (if any).

In Tools, Options, User Interface, View, set custom colours for the page and
master page. It helps as an obvious visual reminder.

In User Interface, Tabs, enable “Auto-expand on full bar,” to make the hidden
studio tabs easier to access. Change the Colour Scheme for the interface here too.

In Task Monitor, disable “Background monitoring of site.” Unless your site is
only ten pages or fewer, background monitoring has a significant effect on perform-
ance.

In Tools, Options, Layout, set the snapping and guides options, and nudge
distance. You might also find it helpful to increase the snapping distance to make
it more obvious when objects have snapped to guides.

In Tools, Options, Graphics, set the value for “Embed pictures by default if
smaller than,” value to 1 Kbyte (type in the value). This will ensure that all images
other than small icons are linked. Backup linked content as well as the WebPlus
project file. Do not embed any content — there are no benefits and many disadvan-
tages. See this thread for example: the time for the user to save the site was reduced
from 15 minutes to just a second or two after linking all embedded content. Large
sites become unusable, unstable, and impractical to backup to the server if media
content is embedded. The risk of losing the entire project is greatly increased too.
Once the site has been published, the linked content is on the server and can be
downloaded easily if you need to recover it. Recovering a corrupted WebPlus project
is seldom easy, and may require a complete rebuild. Do not take that risk!

Link All Content! Do not Embed it!
My three main WebPlus project files are small, and not at all difficult to backup

to the server or to DropBox. Even the largest takes only a few minutes to backup.

http://www.w3schools.com/cssref/css3_pr_box-shadow.asp


Text-heavy sites like mine can be made even smaller for backup purposes by
extracting the contents to a temporary folder then recompressing with 7-Zip using
PPMd compression. WebPlus files are just standard Zip archives.

1. Softer Views: 28 pages, 536 Kbytes (361 Kbytes as a 7z archive)
2. Aimwell.org 270 pages, 4.69 Mbytes (2.36 Mbytes as a 7z archive)
3. DPPN, 3,968 pages, 9.44 Mbytes (1.40 Mbytes as a 7z archive)

User Dictionaries
WebPlus has the same User Dictionary options as PagePlus. However, why add

a whole lot of words again and maintain two pairs of word lists? One can add the
PagePlus user dictionaries to WebPlus, then both programs (or multiple versions of
both programs) will share the same word lists.

Not much has changed in PagePlus X9 in spite of the new Hunspell support.
Added words are still stored in Unicode text files in the Application Data folders.
The file extension of the word list has changed from *.tlx to *.dic but the older *.tlx
files work just the same.

From the Tools Menu, Options, Text, User Dictionaries,
click on the Add... button and browse to the Application Data
folder where your word lists are stored. For PagePlus X7 this
will be in the \Serif\PagePlus\17.0\Languages\ folder. Add
one or more words lists and check “Apply the settings to new
sites,” to save the changes.

If you want to add or remove a lot of words to a list, open the *.tlx or *.dic word
lists in Notepad2 or a similar advanced text editor, and save the files in Unicode Big
Endian format. Notepad2 will automatically recognise the encoding.

Configuring Auto-Correct
In Tools, Options, Text, Auto-Correct, I recommend disabling all options except

for “Convert straight quotes to Typographical Quotes,” and “Capitalise the names
of days.” The other options are more trouble than they are worth.

Edit the replacement list to remove the entries for (a), (c), (r), (tm), 1/2, 1/4, 3/4, and
the various arrows. Note that Auto-Correct replacements are language context-sensitive,
and will not work if no language is selected for the current text. Add entries for technical
terms that you use frequently, but don’t want to spell out in full every time, for example,
you could add entries for WPX8 > WebPlus X8. To add an entry for your website URL
or email address, format it as you wish, select it, then open the Replacements list for
Auto-Correct, and add the entry as formatted text, using a short-form such as URL or
email (whatever works for you). Font size, typeface, and hyperlink formatting are
replaced with the text. An email link can contain a default subject line, etc.

Boiler-plate text can also be added as Auto-Correct entries. For example, I use
one for “abc” to insert “abcdefghijklmnopqrstuvwxyz,” and another for “tsf" to type

“The Sly Fox Jumped Over the Lazy Sleeping Dog.”
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