Customising WebPlus
This tutorial is specific to WebPlus, but some tips also apply to PagePlus,
DrawPlus,, and PhotoPlus. WebPlus allows users to customise the toolbars, menus,
workspace tabs, and keyboard shortcuts. If you use any Serif programs regularly, its
well worth the effort to configure the interface to suit your personal preferences.

Toolbars
See the topic: “Customising Toolbars, Menus, and Tabs” in the help file.

Large Icons
WebPlus X8 has HiDPI support. WebPlus X7 or later have options for small,
large, or auto icons. Import 18 x 18 pixel icons into the Bu�on Editor, or use Paste
Bu�on Image �om the context menu while customising toolbars. In earlier versions
the Windows regis�y can be edited to change the value of the “LargeIcons” key
�om zero to one, e.g. for WebPlus X5 there are two keys:–
[HKEY_CURRENT_USER\So�ware\Serif\WebPlus\13.0\ToolBars\WebPlus\Options]
"LargeIcons"=dword:00000001
[HKEY_CURRENT_USER\So�ware\Serif\WebPlus\13.0\ToolBars\WritePlus\Options]
"LargeIcons"=dword:00000001

Other Serif Applications are similar.

Creating New Toolbars
I recommend adding a new toolbar for each
side of the window where you want to dock
toolbars. Changes are lost if you reset the workspace, so save the workspace and copy the *.wtb
file �om the %AppData% workspace folder to
keep as a backup. Open the Options dialogue �om
the Tools menu, select “Toolbars” and add a new
toolbar. I added one named “Standard Plus.” Display all the toolbars, select the
customize tab on the options dialogue, and drag the toolbars by their handles. The
new toolbars will be emp�. Hold down the con�ol key, and drag icons �om the
default toolbars, dropping a copy onto the new toolbars.
To make changes on the fly, drag bu�ons while holding down the Alt key.
To Change a bu�on, right-click on a bu�on and select “Change Bu�on image”
�om the popup context menu to open the icon pale�e.

Adding A New Flyout
At the bo�om of the customize tab of the options dialogue is the New Menu
category, which contains two commands: New Menu and New Flyout. A new flyout
can be dragged to any toolbar �om the dialogue, or an existing flyout can be copied
by dragging a flyout �om any built-in toolbar by holding down the con�ol key.

Detaching Flyouts
The built-in flyouts can be detached as floating toolbar pale�es. If you open
a flyout, you will see that it has a drag handle. Drag it away �om the toolbar to
detach it as a floating toolbar. The original flyout will not be changed. A floating
toolbar �om a copied flyout bears the name of the original flyout �om which it
was copied. This name cannot be changed. Floating toolbars can also be docked,
and are automatically added to the list of named toolbars in the Options dialogue.

Sites Toolbar
This non-customisable toolbar with tabs for each open site can be docked or
le� floating. It can be set to “Always Hide,” “Show Automatically,” or “Always
Show.” This can be done in Tools, Options, Toolbars, or �om the View menu,
so I have removed the submenu �om the View menu. Since I rarely work on
more than one site at a time it’s usually hidden, and I dock mine on the right
where it is not wasting precious vertical screen real-estate.

Editing Command Buttons
With the customize dialogue open, right-click
on a flyout, bu�on, or menu to edit its properties.
Change the name, the bu�on, or choose the
bu�on s�le: default, text, image and text.
If any command, such as the Acquire
command has no bu�on, a new bu�on can be
chosen �om the list of custom bu�ons, pasted
�om the windows clipboard, or imported �om a
file on disk (Select All Files *.* to include PNG
images). If the image doesn’t have �ansparency,
add it using the Bu�on Editor’s tools. WebPlus
works best with 18 x 18 pixel icons, but the Custom bu�ons provided seem to be
only 16 x 16 pixels. Start by adding a Bu�on for saving the workspace, and use it
�equently while working to avoid losing any changes if you plan on doing any
extensive redesigning of the workspaces.

Menus
The menu bar is similar to other toolbars, except that it cannot be disabled. It can
be undocked and moved to any side of the window, moved below other toolbars,
or le� floating. Bu�ons can be positioned on the menu bar, and new menus can be
added. Menu items can also have icons. For example, create a new menu and drag
the recent files item �om the file menu to this new menu. Rename the “New Menu”
to “&Recent” so that the access key will be Alter R, and change the access key for
Properties to P, or these two menus will not pull down with Alt R. In Tools, Options,
Text, General, increase the number of recently used files �om 4 (max =16). Bu�ons
and fields (e.g. Zoom) can also be added to the menu bar.

Rearrange menus to allow quick access to �equently used
items, remove items that you never use to save space and make
other items quicker to find. Cascading menus should be
avoided if possible as it hinders workflow. The View menu on
the right has been modified to remove all submenus.
The Zoom submenu has been removed. Using shortcuts for
zooming is much quicker, and I have added the zoom drop list
to the Menu Bar. • The Toolbars submenu has been removed.
Right-click on any toolbar to see it. • The Tabs submenu has
been removed as one can right-click on the borders of the Tabs
to show the Tabs menu. Workspaces can be changed �om the
context toolbar when no objects are selected. • The items on
the Select submenu of the Edit menu have been moved to the Edit menu so the
submenu is no longer needed. Using a submenu for just three items is pointless.
Access keys o�en need to be reassigned a�er modi�ing menus. As with the main
menu, avoid using the same access key more than once as it prevents instant access
to menu items. Menu items can be renamed if necessary. Use an Ampersand before
the le�er that you wish to use for the access key.

Workspace Tabs
This topic is dealt with under “Customizing Tabs”
in the Customizing toolbars, menus, and tabs help topic.
It is much quicker to access a con�ol that touches the
edge of the screen because the edges of the screen
effectively have infinite width. With the default workspace there are Tabs on the le� and right of the workspace. That on the right is quick to access, but the Assets
Tab on the le� is inside the toolbar, and any tab docked
at the bo�om will be above the Hintline.
Move the Assets Tab �om the le�, and position it floating at the top, where it
can be set to Auto Hide, utilising the �ee space on the Windows title bar. In this
position, Tabs can be wider. Drag the S�les and Task Monitor Tabs to share the
floating panel with the Assets Tab.
Browse to add some graphics to the Assets Tab, and pin them if you want them
to be available for other documents, but be aware that pinning a lot of large images
will affect the program’s performance.
Save custom workspaces for reloading later. Experiment with different layouts
for different projects. Workspaces are saved in the %AppData% workspace folder,
for WebPlus X8 that is: %AppData%\Serif\WebPlus\16.0\Workspace Profiles\
Don’t forget to save your workspace profile a�er making changes, and backup
any other customisation data in the %AppData% folder to a safe place. Delete the
bitmap caches first if you want to backup the entire folder for WebPlus.

Keyboard Shortcuts
See the topic “Using shortcuts.”
● Con�ol key shortcuts are easy to use, so assign them to the most used functions.
● Alter key shortcuts are reserved for menu access keys so use them with caution
— you might lose easy access to one of the main menus.
● If your scroll lock key has a light, assign it to snapping on/off
● Assign shortcuts for the rulers and hintline, which are not always needed.
● Assign shortcuts to �equently used s�les in the text editing context.
● Backup your keyboard profile in the %AppData% Accelerators folder.

Text S�les
None of the default s�les are likely to be exactly what you want, and you may
never use them all. Before starting work, delete any that you don’t want, and modi�
the others to suit your needs. Open the Text S�les tab in the panel on the right and
click the drop down arrow by a s�le to delete it, modi� it, or create a new s�le based
on it. S�les can also be updated �om the current selection. Add a toolbar bu�on or
shortcut to make this easier.
S�les based on the current s�le will be modified if the current s�le is modified.
S�le hierarchy makes it easy to modi� the s�les throughout a publication, without
modi�ing each one.
You may wish to modi� any of these se�ings for each paragraph s�le:
1. Font, font size, text colour, or �pe s�le.
2. Justification. Full justification is the most common se�ing for body text;
headings may be cen�ed or le� justified. Force Justified fits the last line.
3. Indents. If there is no spacing between body text paragraphs, it is usual to use
a first line indent to emphasise the beginning of each paragraph. Quotations
may be indented �om both margins, and lists may use a hanging indent.
4. Line-spacing can be defined in several ways. The default of single line-spacing
uses a value determined by the font designer. The percentage of pointsize
se�ing is independent of the font’s design. If exact line-spacing is used, and
the font size is later changed, the line-spacing will not change.
5. Spacing before/a�er the current paragraph. Web pages are easier to read with
some white space between paragraphs. Saving space is not as much an issue
as in printed publications.
6. Hyphenation is not supported, but so� hyphens can be inserted with Alt 0173.
7. Bullets and numbering. Chose �om different bullets, numbers, Roman
numerals, or le�ers. Restart numbering of lists �om any number
rop Capitals and Initial Capitals are not available in WebPlus. For a
decorative effect at the beginning of a new section, an Artistic Text character
converted to curves or a graphic can be used. Subsequent lines of text will
wrap automatically around the inline image.
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Nested S�les
The “Heading 1” s�le used above is based on the “Headings” paragraph s�le. On
pressing the Enter key the next paragraph is the “Body Text” s�le. Any changes
made to the Heading 1 s�le will have no effect on the paragraphs that use the “Body
Text” s�le, but they will affect paragraphs that use the “Heading 2” s�le. If the font
is changed, the font used for Heading 2 will change to match. However, if the font
size for Heading 1 is changed the size of the “Heading 2” s�le doesn’t change because
“Heading 2” has its own size of 16 point.
Any changes to the �peface, point size, linespacing, justification, indentation, etc., of the “Body
Text” s�le will be inherited by its nested s�les.
However, any change to the text colour will not be
inherited. The dark green text will be bold, and the
blue text will have 6pt spacing before/a�er, whatever
changes are made to the weight and paragraph
spacing for “Body Text.” However, if the colour of “Heading 1” is changed to Blue,
“Heading 2” will also change to Blue because the text colour was not part of the
“Heading 1” parent s�le on which “Heading 2” depends.

Heading 2
Heading 2 is also followed by “Body Text” on pressing the Enter key. It is le�
aligned instead of being cen�ed, and has 12 points of spacing before it, but none
a�er it. “Body Text” has 2 points of spacing before and a�er, that’s why there is a
gap a�er Heading 2 before this paragraph.
On the General tab of the Modi� Text S�le dialogue, one can find a description
of the s�le a�ibutes that differ �om its parent s�le, on which it is based. In the
above screen shot, you can see that Heading 2 is based on Heading 1, but it is 16
instead of 18 point, and has zero spacing a�er it.
“Body Text” is automatically followed by another paragraph of “Body Text” s�le
on pressing the Enter key.
“Red.” This is Body Text, plus the red colour a𝚛ibute. All paragraphs that use
this s�le will be just like Body Text, but red. Pressing the Enter key in a paragraph
of red text will automatically select the “Green” paragraph s�le for the next paragraph.
“Green.” This is Body Text, plus the green colour a𝚛ibute, and the italic a𝚛ibute. Pressing
the Enter key in a paragraph of green text will automatically select the “Blue” paragraph
s�le for the next paragraph.
“Blue.” This is Body Text, plus the blue colour a�ibute, and an indent on
both sides. Pressing the Enter key in a paragraph of blue text will automatically select the “Red” paragraph s�le for the next paragraph.
This is the “Red” paragraph s�le, which automatically follows text using the “Blue”
paragraph s�le.

Object S�les
HE STYLES TAB in WebPlus contains a wide range of predefined object s�les
that can be applied to quick shapes, text, or other objects. They are grouped
into categories. Add more using the s�les manager.
Anyone with even a li�le artistic skill can quickly create an unlimited range of
designs by playing with quick shapes and objects s�les.
To add, remove, and reorder s�le categories: click
the S�le tab’s menu bu�on and choose Object S�les
Manager... �om the flyout menu.
To locate an object s�le, right-click the object,
and �om Format, Object S�le, select “Locate in Tab.”
This won’t expand a category if it is collapsed, or
display the S�les Tab if it is on Autohide.
Deleting a s�le doesn’t affect the appearance of existing objects using that s�le,
but they are no longer linked to any s�le. To unlink an object �om its s�le definition:
Right-click the object and choose Format, Object S�le, Unlink.
Right-click on a s�le’s icon in the studio tab to edit its a�ibutes. Editing any of
the a�ibutes used in the s�le will unlink the object �om its s�le.
Like Text S�les, Object S�les are saved with the current publication. To save
any object s�les for use in new publications, select Save Default Se�ings �om the
Tools menu, and enable the “Object s�les” checkbox.

CSS S�les
In recent versions of WebPlus, CSS
replaces some of the forma�ing features used
in earlier versions. For example, borders on
text �ames or drop shadows on images can be
applied using CSS Properties, then saved to
the Assets Tab as se�ings to be reapplied to any other objects on the site.
A�er defining the CSS Properties for an
object click on the Assets... bu�on on the
Custom CSS dialogue tab, and save the
se�ings to the Assets Tab. Give it a meaningful
name, and it is then available for reuse elsewhere on the same site.
Although there are lots of options on the CSS Properties dialogue there is almost
no help at all to tell you what values to enter in the various dialogues. You will have
to study some tutorials to find out the right syntax, and as with all such coding, the
slightest error will give unexpected results or no results at all.
See this example thread where I asked how to add a CSS Drop Shadow and found
the solution with the help of more experienced WebPlus users.

Configuring the User Interface
In Tools, Options, General, I recommend disabling “Auto-save temporary file
every 15 minutes.” More o�en than not, this kicks in at just the wrong time. Cultivate
the habit of saving your site every time you make a minor edit, and use the Save As...
option sometimes if you want to keep different revisions. The temporary files will
only recover work if WebPlus crashes, it won’t protect you �om closing the site
without saving changes. Rely on good habits to avoid losing valuable work.
Make backup file on save also won’t protect you �om anything if you lose your
hard drive or your computer gets stolen. Establish a regular backup routine to archive
important work to external media. If you fail to do that, don’t complain on the
forums. It obviously was not important at all if you did not keep a backup.
If you work on the same site most of the time, use the On Startup se�ing to
“Restore Last Session.” This is a huge time-saver on large sites as it remembers not
only the last site or sites that you had open when you last closed WebPlus, but it
remembers which page you were working on at the time, the zoom level, and which
story you were editing in WritePlus (if any).
In Tools, Options, User Interface, View, set custom colours for the page and
master page. It helps as an obvious visual reminder.
In User Interface, Tabs, enable “Auto-expand on full bar,” to make the hidden
studio tabs easier to access. Change the Colour Scheme for the interface here too.
In Task Monitor, disable “Background monitoring of site.” Unless your site is
only ten pages or fewer, background monitoring has a significant effect on performance.
In Tools, Options, Layout, set the snapping and guides options, and nudge
distance. You might also find it helpful to increase the snapping distance to make
it more obvious when objects have snapped to guides.
In Tools, Options, Graphics, set the value for “Embed pictures by default if
smaller than,” value to 1 Kbyte (�pe in the value). This will ensure that all images
other than small icons are linked. Backup linked content as well as the WebPlus
project file. Do not embed any content — there are no benefits and many disadvantages. See this thread for example: the time for the user to save the site was reduced
�om 15 minutes to just a second or two a�er linking all embedded content. Large
sites become unusable, unstable, and impractical to backup to the server if media
content is embedded. The risk of losing the entire project is greatly increased too.
Once the site has been published, the linked content is on the server and can be
downloaded easily if you need to recover it. Recovering a corrupted WebPlus project
is seldom easy, and may require a complete rebuild. Do not take that risk!

Link All Content! Do not Embed it!
My three main WebPlus project files are small, and not at all difficult to backup
to the server or to DropBox. Even the largest takes only a few minutes to backup.

Text-heavy sites like mine can be made even smaller for backup purposes by
ex�acting the contents to a temporary folder then recompressing with 7-Zip using
PPMd compression. WebPlus files are just standard Zip archives.
1. So�er Views: 28 pages, 536 Kbytes (361 Kbytes as a 7z archive)
2. Aimwell.org 270 pages, 4.69 Mbytes (2.36 Mbytes as a 7z archive)
3. DPPN, 3,968 pages, 9.44 Mbytes (1.40 Mbytes as a 7z archive)

User Dictionaries
WebPlus has the same User Dictionary options as PagePlus. However, why add
a whole lot of words again and maintain two pairs of word lists? One can add the
PagePlus user dictionaries to WebPlus, then both programs (or multiple versions of
both programs) will share the same word lists.
Not much has changed in PagePlus X9 in spite of the new Hunspell support.
Added words are still stored in Unicode text files in the Application Data folders.
The file extension of the word list has changed �om *.tlx to *.dic but the older *.tlx
files work just the same.
From the Tools Menu, Options, Text, User Dictionaries,
click on the Add... bu�on and browse to the Application Data
folder where your word lists are stored. For PagePlus X7 this
will be in the \Serif\PagePlus\17.0\Languages\ folder. Add
one or more words lists and check “Apply the se�ings to new
sites,” to save the changes.
If you want to add or remove a lot of words to a list, open the *.tlx or *.dic word
lists in Notepad2 or a similar advanced text editor, and save the files in Unicode Big
Endian format. Notepad2 will automatically recognise the encoding.

Configuring Auto-Correct
In Tools, Options, Text, Auto-Correct, I recommend disabling all options except
for “Convert s�aight quotes to Typographical Quotes,” and “Capitalise the names
of days.” The other options are more �ouble than they are worth.
Edit the replacement list to remove the en�ies for (a), (c), (r), (tm), 1/2, 1/4, 3/4, and
the various arrows. Note that Auto-Correct replacements are language context-sensitive,
and will not work if no language is selected for the current text. Add en�ies for technical
terms that you use �equently, but don’t want to spell out in full every time, for example,
you could add en�ies for WPX8 > WebPlus X8. To add an en�y for your website URL
or email address, format it as you wish, select it, then open the Replacements list for
Auto-Correct, and add the en�y as forma�ed text, using a short-form such as URL or
email (whatever works for you). Font size, �peface, and hyperlink forma�ing are
replaced with the text. An email link can contain a default subject line, etc.
Boiler-plate text can also be added as Auto-Correct en�ies. For example, I use
one for “abc” to insert “abcdefghijklmnopqrstuvwxyz,” and another for “tsf" to �pe
“The Sly Fox Jumped Over the Lazy Sleeping Dog.”

